summaryrefslogtreecommitdiff
path: root/dev-ruby/psych/psych-4.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/psych/psych-4.0.6.ebuild')
-rw-r--r--dev-ruby/psych/psych-4.0.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/psych/psych-4.0.6.ebuild b/dev-ruby/psych/psych-4.0.6.ebuild
new file mode 100644
index 000000000000..a4a17602ae46
--- /dev/null
+++ b/dev-ruby/psych/psych-4.0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/psych/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A YAML parser and emitter"
+HOMEPAGE="https://github.com/ruby/psych"
+
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="test"
+
+RDEPEND+=" >=dev-libs/libyaml-0.2.5"
+BDEPEND+=" >=dev-libs/libyaml-0.2.5"
+
+ruby_add_rdepend "dev-ruby/stringio"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}