summaryrefslogtreecommitdiff
path: root/dev-ruby/pkg-config/pkg-config-1.4.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pkg-config/pkg-config-1.4.9.ebuild')
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.4.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/pkg-config/pkg-config-1.4.9.ebuild b/dev-ruby/pkg-config/pkg-config-1.4.9.ebuild
new file mode 100644
index 000000000000..d8aebeb67680
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.4.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+ sed -e '/test_cflags/aomit "Fragile on Gentoo"' -i test/test-pkg-config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test-pkg-config.rb || die
+}