summaryrefslogtreecommitdiff
path: root/dev-ruby/pdf-reader/pdf-reader-2.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pdf-reader/pdf-reader-2.4.2.ebuild')
-rw-r--r--dev-ruby/pdf-reader/pdf-reader-2.4.2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-ruby/pdf-reader/pdf-reader-2.4.2.ebuild b/dev-ruby/pdf-reader/pdf-reader-2.4.2.ebuild
deleted file mode 100644
index 1b2ec2c23b48..000000000000
--- a/dev-ruby/pdf-reader/pdf-reader-2.4.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-GITHUB_USER=yob
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md TODO"
-
-RUBY_FAKEGEM_GEMSPEC="pdf-reader.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="PDF parser conforming as much as possible to the PDF specification from Adobe"
-HOMEPAGE="https://github.com/yob/pdf-reader/"
-
-# We cannot use the gem distributions because they don't contain the
-# tests' data, we have to rely on the git tags.
-SRC_URI="https://github.com/${GITHUB_USER}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND+=" !!<dev-ruby/pdf-reader-1.4.1-r2"
-
-ruby_add_rdepend ">=dev-ruby/afm-0.2.1 =dev-ruby/afm-0.2*
- =dev-ruby/ascii85-1*
- =dev-ruby/hashery-2*
- dev-ruby/ttfunk:*
- dev-ruby/ruby-rc4"
-
-all_ruby_prepare() {
- # Remove bundler support
- sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*
-}