summaryrefslogtreecommitdiff
path: root/dev-ruby/parallel
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/parallel')
-rw-r--r--dev-ruby/parallel/Manifest3
-rw-r--r--dev-ruby/parallel/metadata.xml11
-rw-r--r--dev-ruby/parallel/parallel-1.12.1.ebuild55
3 files changed, 0 insertions, 69 deletions
diff --git a/dev-ruby/parallel/Manifest b/dev-ruby/parallel/Manifest
deleted file mode 100644
index c75407b8a3b0..000000000000
--- a/dev-ruby/parallel/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST parallel-1.12.1.tar.gz 20499 BLAKE2B f0fa25b9fe65e44804854f703dd2d80e53572e64c2072c418d0462922bd04f89cff0e023caf4293d8a1504ad66a2a29ebbdd01920fc6fe400837859da0f0eb78 SHA512 f0ab332dfa60bb3190bba8275dbdf7b54d3de205ab76099d11f0a64e1fc28e1ba7e72d1a242bd615015c2d09a3f08df01c382869fd6990b854b01fe182245857
-EBUILD parallel-1.12.1.ebuild 1704 BLAKE2B aa611882ab0f456cb396e5fb9ed4f343dd305d0ac863931fff605a095ac4d906b9dce2e82abdad675809bfb2b3247e0b217dfbe7aa7491d0ce091805d19e6da5 SHA512 e83fdf5fcf0f5fdf80d3e8e8aace77935171e17ab0a315d8eab5c0e2c383cc0ed026d528450f93529862c38968aa19218239441f9a4e990336ed647c53d5c865
-MISC metadata.xml 342 BLAKE2B 0860273d70423cb92207369335e1f684ea623e1217d7aaf4d016d9aff9c02b0b8dc9af3654b523f77cbd8d92f7043887a97ff87abb79d3c65b66b0e6b40082fb SHA512 805eaecfea071b1d632ade7da42ed63717d2f829c4c99e29a4600b26a81e87c4032d7ee441b865d86f37faa13f455c9f2888dc8099178cf6211ae13d3e3e1835
diff --git a/dev-ruby/parallel/metadata.xml b/dev-ruby/parallel/metadata.xml
deleted file mode 100644
index 9342377f9242..000000000000
--- a/dev-ruby/parallel/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">grosser/parallel</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/parallel/parallel-1.12.1.ebuild b/dev-ruby/parallel/parallel-1.12.1.ebuild
deleted file mode 100644
index 05fc01153dbe..000000000000
--- a/dev-ruby/parallel/parallel-1.12.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
- test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:5.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
- # Make sure the correct ruby is used for testing
- sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e '1i require "tempfile"; gem "activerecord", "~>5.2.0"' spec/cases/helper.rb || die
- sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
- # Avoid a failing spec regarding to pipes. The spec seems like it
- # should always fail.
- sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
- -i spec/parallel_spec.rb || die
-
- # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
- sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-
- # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
- sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
- # Set RUBYLIB explicitly for the ruby's that get started from the specs.
- TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}