summaryrefslogtreecommitdiff
path: root/dev-ruby/nio4r/nio4r-2.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/nio4r/nio4r-2.6.1.ebuild')
-rw-r--r--dev-ruby/nio4r/nio4r-2.6.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-ruby/nio4r/nio4r-2.6.1.ebuild b/dev-ruby/nio4r/nio4r-2.6.1.ebuild
index 381b1a8e8790..6fe4a3605cb9 100644
--- a/dev-ruby/nio4r/nio4r-2.6.1.ebuild
+++ b/dev-ruby/nio4r/nio4r-2.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ RUBY_FAKEGEM_EXTRADOC="changes.md readme.md"
RUBY_FAKEGEM_EXTENSIONS=(ext/nio4r/extconf.rb)
-inherit ruby-fakegem
+inherit flag-o-matic ruby-fakegem
DESCRIPTION="A high performance selector API for monitoring IO objects"
HOMEPAGE="https://github.com/socketry/nio4r"
@@ -26,6 +26,10 @@ IUSE=""
# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
all_ruby_prepare() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
sed -e '/extension/ s:^:#:' -i Rakefile || die
}