summaryrefslogtreecommitdiff
path: root/dev-ruby/nio4r/nio4r-2.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/nio4r/nio4r-2.5.2.ebuild')
-rw-r--r--dev-ruby/nio4r/nio4r-2.5.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/nio4r/nio4r-2.5.2.ebuild b/dev-ruby/nio4r/nio4r-2.5.2.ebuild
new file mode 100644
index 000000000000..a0396fa1cc8f
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-2.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/socketry/nio4r"
+
+LICENSE="MIT || ( BSD GPL-2 )"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-retry )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/*$(get_modname) lib/ || die
+}