summaryrefslogtreecommitdiff
path: root/dev-ruby/netrc/netrc-0.11.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/netrc/netrc-0.11.0-r1.ebuild')
-rw-r--r--dev-ruby/netrc/netrc-0.11.0-r1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-ruby/netrc/netrc-0.11.0-r1.ebuild b/dev-ruby/netrc/netrc-0.11.0-r1.ebuild
deleted file mode 100644
index aff7a3f79c01..000000000000
--- a/dev-ruby/netrc/netrc-0.11.0-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_EXTRADOC="changelog.txt Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="This library reads and writes .netrc files"
-HOMEPAGE="https://github.com/geemus/netrc"
-LICENSE="MIT"
-
-KEYWORDS="amd64 ~arm ~arm64 x86"
-SLOT="0"
-IUSE=""
-
-all_ruby_prepare() {
- # Avoid broken test that wrongly tests ruby internal code, bug 643922
- sed -e '/test_encrypted_roundtrip/,/^ end/ s:^:#:' \
- -e '/test_missing_environment/,/^ end/ s:^:#:' \
- -e "s:/tmp/:${T}/:" \
- -i test/test_netrc.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
-}