summaryrefslogtreecommitdiff
path: root/dev-ruby/msgpack/msgpack-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/msgpack/msgpack-1.6.0.ebuild')
-rw-r--r--dev-ruby/msgpack/msgpack-1.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/msgpack-1.6.0.ebuild b/dev-ruby/msgpack/msgpack-1.6.0.ebuild
new file mode 100644
index 000000000000..4330306ef185
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-1.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.md"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/msgpack/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/msgpack"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="https://msgpack.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove jruby-specific specs that are run also for other rubies.
+ rm -rf spec/jruby || die
+
+ sed -i -e 's/git ls-files/find * -print/' msgpack.gemspec || die
+}