summaryrefslogtreecommitdiff
path: root/dev-ruby/minitest-hooks/minitest-hooks-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/minitest-hooks/minitest-hooks-1.4.1.ebuild')
-rw-r--r--dev-ruby/minitest-hooks/minitest-hooks-1.4.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ruby/minitest-hooks/minitest-hooks-1.4.1.ebuild b/dev-ruby/minitest-hooks/minitest-hooks-1.4.1.ebuild
new file mode 100644
index 000000000000..dbb399a01c02
--- /dev/null
+++ b/dev-ruby/minitest-hooks/minitest-hooks-1.4.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+# Skip tests since they require unpackaged sequel
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds around and before_all/after_all/around_all hooks for Minitest"
+HOMEPAGE="https://github.com/jeremyevans/minitest-hooks"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64"
+IUSE=""