summaryrefslogtreecommitdiff
path: root/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild')
-rw-r--r--dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
index c1444d3859dc..f4b8a550ce61 100644
--- a/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
+++ b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
@@ -29,6 +29,11 @@ all_ruby_prepare() {
-i test/helper.rb Rakefile || die
}
+each_ruby_prepare() {
+ sed -e "/spawn_test/,/^end/ s:ruby:${RUBY}:" \
+ -i test/around_spec.rb || die
+}
+
each_ruby_test() {
for f in test/*_{test,spec}.rb ; do
${RUBY} -S rake test:isolated TEST="${f}" || die