summaryrefslogtreecommitdiff
path: root/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-07 00:08:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-07 00:08:01 +0100
commit941687623283212199cbe6e36f7d61b89d6222b2 (patch)
treeba7fb5198fd46b0b501a9c4362be2c26738408ad /dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
parent44cec61076bf2bbb3cea1fc89943dd6818a5acc5 (diff)
gentoo auto-resync : 07:06:2024 - 00:08:01
Diffstat (limited to 'dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild')
-rw-r--r--dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
index c1444d3859dc..f4b8a550ce61 100644
--- a/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
+++ b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
@@ -29,6 +29,11 @@ all_ruby_prepare() {
-i test/helper.rb Rakefile || die
}
+each_ruby_prepare() {
+ sed -e "/spawn_test/,/^end/ s:ruby:${RUBY}:" \
+ -i test/around_spec.rb || die
+}
+
each_ruby_test() {
for f in test/*_{test,spec}.rb ; do
${RUBY} -S rake test:isolated TEST="${f}" || die