summaryrefslogtreecommitdiff
path: root/dev-ruby/kpeg/kpeg-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/kpeg/kpeg-1.2.0.ebuild')
-rw-r--r--dev-ruby/kpeg/kpeg-1.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/kpeg/kpeg-1.2.0.ebuild b/dev-ruby/kpeg/kpeg-1.2.0.ebuild
new file mode 100644
index 000000000000..7178cd2d934c
--- /dev/null
+++ b/dev-ruby/kpeg/kpeg-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple PEG library for Ruby"
+HOMEPAGE="https://github.com/evanphx/kpeg"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+PATCHES=( "${FILESDIR}/kpeg-1.1.0-utf8.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "minitest", "~>5.0"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}