summaryrefslogtreecommitdiff
path: root/dev-ruby/instance_storage/instance_storage-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/instance_storage/instance_storage-2.0.0.ebuild')
-rw-r--r--dev-ruby/instance_storage/instance_storage-2.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/instance_storage/instance_storage-2.0.0.ebuild b/dev-ruby/instance_storage/instance_storage-2.0.0.ebuild
new file mode 100644
index 000000000000..300c6ade262e
--- /dev/null
+++ b/dev-ruby/instance_storage/instance_storage-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+DESCRIPTION="Manage class instances with dictionary"
+HOMEPAGE="https://rubygems.org/gems/instance_storage/"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/instance_storage_test.rb || die
+}