summaryrefslogtreecommitdiff
path: root/dev-ruby/http-accept/http-accept-2.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/http-accept/http-accept-2.2.0.ebuild')
-rw-r--r--dev-ruby/http-accept/http-accept-2.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/http-accept/http-accept-2.2.0.ebuild b/dev-ruby/http-accept/http-accept-2.2.0.ebuild
new file mode 100644
index 000000000000..4cfb7baa55fc
--- /dev/null
+++ b/dev-ruby/http-accept/http-accept-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="http-accept.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse Accept and Accept-Language HTTP headers"
+HOMEPAGE="https://github.com/socketry/http-accept"
+SRC_URI="https://github.com/socketry/http-accept/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
+ sed -e 's:_relative ": "./:' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}