summaryrefslogtreecommitdiff
path: root/dev-ruby/http
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/http')
-rw-r--r--dev-ruby/http/Manifest2
-rw-r--r--dev-ruby/http/http-5.1.1.ebuild58
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-ruby/http/Manifest b/dev-ruby/http/Manifest
index 37903f078864..2789c4e5a0b3 100644
--- a/dev-ruby/http/Manifest
+++ b/dev-ruby/http/Manifest
@@ -1,5 +1,3 @@
-DIST http-5.1.1.gem 82944 BLAKE2B bd44ede401712ddd13b76f9e3266622aefd78f37a89c84217c7f8206214e9e2ee994fe375a6e7897315dd83853d4e8ab2c0c9c34a59fe47c1a0617f3c126fdab SHA512 a39d88297b6f2f0a51a22fe502d1f7883d44a3fa0af250e1a8142f093fb3865b02b797bc46780d9129f0c67e18f97cc551aa1dbd794b3b4cda6bdb5495fe95e3
DIST http-5.2.0.gem 85504 BLAKE2B 60391b959752c63e2f8cffcb86d6aad47fd30817f348ac6fc28ebce4fa5186f482c08db5e4413fc84eb54a9beb2682260c0c7241a76b40c3489fe7f2abcfb154 SHA512 88a813498db68827ea665c3a568ce45b0096203484564f3de18d46abdd87d2ecd756745f9f530965db306f8e37185d3d0b31959082bbe01fee5545b36b0716bd
-EBUILD http-5.1.1.ebuild 1728 BLAKE2B 44ddda84a519ab6e095954d2c4d69bbd8578f85a29b939d4555ce48d615857edd7446bdb7111dd886cc5f76d49368ec9031be2246d30246c5faedbbbb4ab284c SHA512 430bbf4d0caf9a9b13df27ddc99a198a6b68053caf34952b5f2a56132eba9d43e7067f7d128e6d00e5644cad8c6b73d75cdc2dd2ef13a1a9330cbef9efe1401f
EBUILD http-5.2.0.ebuild 1770 BLAKE2B 72aa7f707ebe2a609b3d222ce3404ff77be5211b9e84a921897a2aad6ed475cf368979ef5acbb18752b46e7226575a40834720425bcdaf7d7bc20379a449fc1d SHA512 dac25a5389228200603e08629bafd3a5a7fb159ad44a9cd796a7ba74d2b0ae474131a60ecf48fda16c355f7aa793a5ff6ee0c4dc976776aa72c4daff1febaac9
MISC metadata.xml 338 BLAKE2B ad560bb9b4db1783ceef0b3ec0730daf1526b194408e68a65e99f82049ad0b0fe6c99001c7d3af8fa1bdaafcfcf07fb0a3c68b1fb2703ee9ffa5f717e10719a4 SHA512 8008f3f25d0f77a136f5016285a479a488ddb1346c3c75bf897308d7c84918ffa462667c9c97f9259e509ced53d554088b09dd86625d230d73348de09786af31
diff --git a/dev-ruby/http/http-5.1.1.ebuild b/dev-ruby/http/http-5.1.1.ebuild
deleted file mode 100644
index 7f619c9f3bc7..000000000000
--- a/dev-ruby/http/http-5.1.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-inherit ruby-fakegem
-
-DESCRIPTION="An easy-to-use client library for making requests from Ruby"
-HOMEPAGE="https://github.com/tarcieri/http"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-ruby_add_rdepend "=dev-ruby/addressable-2*
- >=dev-ruby/addressable-2.8
- =dev-ruby/http-cookie-1*
- >=dev-ruby/http-form_data-2.2:2
- >=dev-ruby/llhttp-ffi-0.4.0:0/0.4"
-
-ruby_add_bdepend "
- test? (
- =dev-ruby/certificate_authority-1*
- dev-ruby/rspec-its
- dev-ruby/webrick
- )"
-
-all_ruby_prepare() {
- # Avoid specs that require network access
- sed -i -e '/.persistent/,/^ end/ s:^:#:' \
- spec/lib/http_spec.rb || die
- sed -i -e '/with non-ASCII URLs/,/^ end/ s:^:#:' \
- spec/lib/http/client_spec.rb || die
-
- # Avoid spec that may fail with a running web server
- sed -i -e '/unifies socket errors into HTTP::ConnectionError/,/^ end/ s:^:#:' spec/lib/http_spec.rb || die
-
- # Fix spec for production release
- sed -i -e '/User-Agent:/ s/.dev//' spec/lib/http/features/logging_spec.rb || die
-
- # Avoid specs also failing upstream due to some certificate issue
- sed -i -e '/context "ssl"/,/^ end/ s:^:#:' spec/lib/http_spec.rb || die
- sed -i -e '/describe "working with SSL"/,/^ end/ s:^:#:' spec/lib/http/client_spec.rb || die
-
- # Disable coverage
- sed -i -e 's/require_relative ".\/support\/simplecov"//g' "spec/spec_helper.rb" || die
-}
-
-each_ruby_test() {
- # disables dev-ruby/fuubar dep
- CI=1 each_fakegem_test
-}