summaryrefslogtreecommitdiff
path: root/dev-ruby/hiera/hiera-3.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hiera/hiera-3.10.0.ebuild')
-rw-r--r--dev-ruby/hiera/hiera-3.10.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/hiera/hiera-3.10.0.ebuild b/dev-ruby/hiera/hiera-3.10.0.ebuild
new file mode 100644
index 000000000000..39078c3c81bf
--- /dev/null
+++ b/dev-ruby/hiera/hiera-3.10.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="https://docs.puppet.com/hiera/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/deep_merge"