summaryrefslogtreecommitdiff
path: root/dev-ruby/hashr/hashr-2.0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hashr/hashr-2.0.1-r1.ebuild')
-rw-r--r--dev-ruby/hashr/hashr-2.0.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/hashr/hashr-2.0.1-r1.ebuild b/dev-ruby/hashr/hashr-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..1439b1e1660f
--- /dev/null
+++ b/dev-ruby/hashr/hashr-2.0.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Hash extension to make working with nested hashes easier"
+HOMEPAGE="https://github.com/svenfuchs/hashr"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '1i require "spec_helper"' spec/hashr/delegate/conditional_spec.rb || die
+}