summaryrefslogtreecommitdiff
path: root/dev-ruby/hashery/hashery-2.1.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hashery/hashery-2.1.2-r1.ebuild')
-rw-r--r--dev-ruby/hashery/hashery-2.1.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/hashery/hashery-2.1.2-r1.ebuild b/dev-ruby/hashery/hashery-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..d324e3ecfdf4
--- /dev/null
+++ b/dev-ruby/hashery/hashery-2.1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Hashery is a tight collection of Hash-like classes"
+HOMEPAGE="https://rubyworks.github.com/hashery"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/lemon
+ dev-ruby/qed
+ dev-ruby/rubytest
+ dev-ruby/rubytest-cli )"
+
+each_ruby_test() {
+ ${RUBY} -S qed || die 'tests failed'
+ ${RUBY} -S rubytest -Ilib -Itest test/ || die 'tests failed'
+}