summaryrefslogtreecommitdiff
path: root/dev-ruby/hashdiff/hashdiff-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/hashdiff/hashdiff-1.1.0.ebuild')
-rw-r--r--dev-ruby/hashdiff/hashdiff-1.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/hashdiff/hashdiff-1.1.0.ebuild b/dev-ruby/hashdiff/hashdiff-1.1.0.ebuild
new file mode 100644
index 000000000000..6bfae08f4937
--- /dev/null
+++ b/dev-ruby/hashdiff/hashdiff-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Hash extension to make working with nested hashes easier"
+HOMEPAGE="https://github.com/liufengyun/hashdiff"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+}