summaryrefslogtreecommitdiff
path: root/dev-ruby/globalid/globalid-0.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/globalid/globalid-0.5.2.ebuild')
-rw-r--r--dev-ruby/globalid/globalid-0.5.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/globalid/globalid-0.5.2.ebuild b/dev-ruby/globalid/globalid-0.5.2.ebuild
new file mode 100644
index 000000000000..8795d175a2a6
--- /dev/null
+++ b/dev-ruby/globalid/globalid-0.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="globalid.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reference models by URI"
+HOMEPAGE="https://github.com/rails/globalid"
+SRC_URI="https://github.com/rails/globalid/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler >=dev-ruby/activemodel-5.0 >=dev-ruby/railties-5.0 )"
+ruby_add_rdepend ">=dev-ruby/activesupport-5.0:*"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+
+ sed -i -e '2irequire "forwardable"' test/helper.rb || die
+}