summaryrefslogtreecommitdiff
path: root/dev-ruby/file-tail
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/file-tail')
-rw-r--r--dev-ruby/file-tail/Manifest4
-rw-r--r--dev-ruby/file-tail/file-tail-1.2.0-r1.ebuild38
-rw-r--r--dev-ruby/file-tail/file-tail-1.3.0.ebuild4
3 files changed, 3 insertions, 43 deletions
diff --git a/dev-ruby/file-tail/Manifest b/dev-ruby/file-tail/Manifest
index 6eb06664bdb2..5c263ae6170b 100644
--- a/dev-ruby/file-tail/Manifest
+++ b/dev-ruby/file-tail/Manifest
@@ -1,5 +1,3 @@
-DIST file-tail-1.2.0.gem 19968 BLAKE2B 8a9ef8b73d2e7c8c21ec04e817991ebe40ba62800e565b607dbae9732b0192074cff4b3fc9dc7a495be9a2315eab63b48126e524091d72b37f7e8261cb1333f1 SHA512 ac20e5e855144f7462ef0471be08ab56e521a7b22117f1653e06624e1d81ac11d047a21a6979476bc8547dd88d90f25e51052950148acbe3ea64bdd3c35e1da3
DIST file-tail-1.3.0.gem 20992 BLAKE2B ecb15f77cabebc9f048888eba2ae2b1b49e66cbbb6143c84a8f98e98f5f6f9480da0b1652b24adfcc826c318d84238e980b3309a0ab1782d6065cb0242726ac5 SHA512 225f73895d76f4c7db37dc891603cf9c7cd6a188c30cd6a19c758cb470ff89d3beb0887cd7bc052c846236b56384a928277c53dfe9e9adef60d35f4fe2f0d0f5
-EBUILD file-tail-1.2.0-r1.ebuild 820 BLAKE2B 6bb14f202ac0aadebd420f2d4b8eca63c48974eea8ef2e12e3b82b4ec56d69863cf30f423bcb799520b50a3b97fe96ba3eb996fa3af221d68eaf91efbbdb229a SHA512 9d54e8ad1162182a8bb4604b3c1eec24fc72e000a89b6113f1819fdd51d79fbf80dbec9f263744481cad1168857c9323ca00cc2dc792a2c78d667c180181d064
-EBUILD file-tail-1.3.0.ebuild 781 BLAKE2B 99732d4deaab16e3014c5146eef7eada1a0743a916c2c85a143148b2b8aaf763844099645e30ed3a79a582bb99313750fa9fb60af56974cc656f5eed76888ad9 SHA512 f1d8417a31c2138c63a312affab110f51993d660ca4fae6bb6495d8f0267014a9352fa1a998ec168562b00a2e30ac10f16f04c90d0b10d31e956a901f6b4551a
+EBUILD file-tail-1.3.0.ebuild 788 BLAKE2B d659db14ca2c05339fcaf3eee35c7d929c00f89f2a6fdcb357ae9d881aeb6b46d8a7f422868f8142a2301c03f79ef4193b94ed5c9b680fece630f1d7a7aa51b2 SHA512 5129e95a23c7993b0ba4ac102efb64ce965b169f5ff94e7ecec15449b3339e6153db0143a719b3efceb4eca52f375733747912423278ba54024b999db0496d7e
MISC metadata.xml 248 BLAKE2B 0c876bde3c72e61d28284a95a837103e6d594c9f6fccbd6d7d1039f9c5a604347c20c334c9a57d80b152888fed536196f2807b477e8d0336c80affb0e28c9dc9 SHA512 b2b64178cf6cbbaa5fb4671ffe1ab88b83c920de363ae099ef74fa3e5eb8c8f0285c749cabc0cebf344951503d1b7309ae294afe9e7cf5172700182d8843fa14
diff --git a/dev-ruby/file-tail/file-tail-1.2.0-r1.ebuild b/dev-ruby/file-tail/file-tail-1.2.0-r1.ebuild
deleted file mode 100644
index 752ea7517b83..000000000000
--- a/dev-ruby/file-tail/file-tail-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_RECIPE_TEST="none"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_DOC_SOURCES="lib README.md"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A small ruby library that allows it to 'tail' files in Ruby"
-HOMEPAGE="https://flori.github.io/file-tail/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend "=dev-ruby/tins-1*"
-ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
-
-all_ruby_prepare() {
- sed -i -e '/test_tail_change2/aomit "has race condition"' tests/file_tail_test.rb || die
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 -Ilib tests/*_test.rb
-
- rm -f test.*
-}
diff --git a/dev-ruby/file-tail/file-tail-1.3.0.ebuild b/dev-ruby/file-tail/file-tail-1.3.0.ebuild
index e323c0191884..57f30b27d5b6 100644
--- a/dev-ruby/file-tail/file-tail-1.3.0.ebuild
+++ b/dev-ruby/file-tail/file-tail-1.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby31 ruby32 ruby33"
+USE_RUBY="ruby31 ruby32 ruby33 ruby34"
RUBY_FAKEGEM_RECIPE_TEST="none"