summaryrefslogtreecommitdiff
path: root/dev-ruby/fiber-storage/fiber-storage-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/fiber-storage/fiber-storage-0.1.1.ebuild')
-rw-r--r--dev-ruby/fiber-storage/fiber-storage-0.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/fiber-storage/fiber-storage-0.1.1.ebuild b/dev-ruby/fiber-storage/fiber-storage-0.1.1.ebuild
new file mode 100644
index 000000000000..bba7d7fff53a
--- /dev/null
+++ b/dev-ruby/fiber-storage/fiber-storage-0.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="sus"
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="fiber-storage.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a compatibility shim for fiber storage"
+HOMEPAGE="https://github.com/ioquatix/fiber-storage"
+SRC_URI="https://github.com/ioquatix/fiber-storage/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ rm -f config/sus.rb || die
+}