summaryrefslogtreecommitdiff
path: root/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild')
-rw-r--r--dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild b/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild
deleted file mode 100644
index 8001a57b69e0..000000000000
--- a/dev-ruby/fast-stemmer/fast-stemmer-1.0.2-r2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Simple wrapper around multithreaded Porter stemming algorithm"
-HOMEPAGE="https://github.com/romanbsd/fast-stemmer"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE=""
-
-all_ruby_prepare() {
- rm ext/Makefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext
- cp ext/stemmer$(get_modname) lib/ || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S testrb-2 test/fast_stemmer_test.rb || die
-}