summaryrefslogtreecommitdiff
path: root/dev-ruby/erubi/erubi-1.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/erubi/erubi-1.11.0.ebuild')
-rw-r--r--dev-ruby/erubi/erubi-1.11.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/erubi/erubi-1.11.0.ebuild b/dev-ruby/erubi/erubi-1.11.0.ebuild
new file mode 100644
index 000000000000..a49d6b908efe
--- /dev/null
+++ b/dev-ruby/erubi/erubi-1.11.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_GEMSPEC="erubi.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="a ERB template engine for ruby; a simplified fork of Erubis"
+HOMEPAGE="https://github.com/jeremyevans/erubi"
+SRC_URI="https://github.com/jeremyevans/erubi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/minitest-global_expectations )"