summaryrefslogtreecommitdiff
path: root/dev-ruby/diff-lcs/diff-lcs-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/diff-lcs/diff-lcs-1.3.ebuild')
-rw-r--r--dev-ruby/diff-lcs/diff-lcs-1.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ruby/diff-lcs/diff-lcs-1.3.ebuild b/dev-ruby/diff-lcs/diff-lcs-1.3.ebuild
new file mode 100644
index 000000000000..7b1451f64f58
--- /dev/null
+++ b/dev-ruby/diff-lcs/diff-lcs-1.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use the McIlroy-Hunt LCS algorithm to compute differences"
+HOMEPAGE="https://github.com/halostatue/diff-lcs"
+
+LICENSE="|| ( MIT Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""