summaryrefslogtreecommitdiff
path: root/dev-ruby/date_validator/date_validator-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/date_validator/date_validator-0.10.0.ebuild')
-rw-r--r--dev-ruby/date_validator/date_validator-0.10.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-ruby/date_validator/date_validator-0.10.0.ebuild b/dev-ruby/date_validator/date_validator-0.10.0.ebuild
index 474a36c5ed7e..8d4f4549e483 100644
--- a/dev-ruby/date_validator/date_validator-0.10.0.ebuild
+++ b/dev-ruby/date_validator/date_validator-0.10.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_TASK_TEST="test"
@@ -18,7 +18,7 @@ RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
inherit ruby-fakegem
-DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
+DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails"
HOMEPAGE="https://github.com/codegram/date_validator"
LICENSE="MIT"
@@ -44,5 +44,5 @@ all_ruby_prepare() {
sed -i \
-e '/[Bb]undler/s/^/#/' Rakefile || die
# Fix tests
- sed -i -e "1irequire 'active_support'" test/test_helper.rb || die
+ sed -i -e "1irequire 'active_support'; require 'active_support/core_ext/time/zones'" test/test_helper.rb || die
}