summaryrefslogtreecommitdiff
path: root/dev-ruby/daemons/daemons-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/daemons/daemons-1.4.1.ebuild')
-rw-r--r--dev-ruby/daemons/daemons-1.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/daemons/daemons-1.4.1.ebuild b/dev-ruby/daemons/daemons-1.4.1.ebuild
new file mode 100644
index 000000000000..54b393dd44b2
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="daemons.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="https://github.com/thuehlinger/daemons"
+SRC_URI="https://github.com/thuehlinger/daemons/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_prepare() {
+ sed -i -e '/\(pry\|simplecov\)/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples && dodoc -r examples
+}