summaryrefslogtreecommitdiff
path: root/dev-ruby/coolio/coolio-1.7.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/coolio/coolio-1.7.1-r1.ebuild')
-rw-r--r--dev-ruby/coolio/coolio-1.7.1-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-ruby/coolio/coolio-1.7.1-r1.ebuild b/dev-ruby/coolio/coolio-1.7.1-r1.ebuild
index ce243d72a5a8..030b833390e9 100644
--- a/dev-ruby/coolio/coolio-1.7.1-r1.ebuild
+++ b/dev-ruby/coolio/coolio-1.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
RUBY_FAKEGEM_EXTENSIONS=(ext/cool.io/extconf.rb ext/iobuffer/extconf.rb)
-inherit ruby-fakegem
+inherit flag-o-matic ruby-fakegem
DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
HOMEPAGE="https://coolio.github.io/"
@@ -26,6 +26,10 @@ IUSE=""
# cool.io includes a bundled version of libev that is patched to work correctly with ruby.
all_ruby_prepare() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
rm -r Gemfile* lib/.gitignore || die
sed -i -e '/[Bb]undler/d' Rakefile || die