summaryrefslogtreecommitdiff
path: root/dev-ruby/bunny/bunny-2.22.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bunny/bunny-2.22.0.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-2.22.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.22.0.ebuild b/dev-ruby/bunny/bunny-2.22.0.ebuild
new file mode 100644
index 000000000000..f4b63d206dcb
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.22.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31"
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="bunny.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/ruby-amqp/bunny"
+SRC_URI="https://github.com/ruby-amqp/bunny/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/amq-protocol-2.3.1:2
+ >=dev-ruby/sorted_set-1.0.2:0"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files --/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}