summaryrefslogtreecommitdiff
path: root/dev-ruby/bindata/bindata-2.4.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bindata/bindata-2.4.10.ebuild')
-rw-r--r--dev-ruby/bindata/bindata-2.4.10.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/bindata/bindata-2.4.10.ebuild b/dev-ruby/bindata/bindata-2.4.10.ebuild
new file mode 100644
index 000000000000..2f797ad91789
--- /dev/null
+++ b/dev-ruby/bindata/bindata-2.4.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parsing Binary Data in Ruby"
+HOMEPAGE="https://github.com/dmendel/bindata"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '/[Cc]overalls/d' test/test_helper.rb || die
+}