summaryrefslogtreecommitdiff
path: root/dev-ruby/asciidoctor/asciidoctor-2.0.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/asciidoctor/asciidoctor-2.0.16.ebuild')
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-2.0.16.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/asciidoctor-2.0.16.ebuild b/dev-ruby/asciidoctor/asciidoctor-2.0.16.ebuild
new file mode 100644
index 000000000000..4ab9f1c81857
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-2.0.16.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="CUCUMBER_PUBLISH_QUIET=true test features"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="asciidoctor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/concurrent-ruby
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/rouge
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}