summaryrefslogtreecommitdiff
path: root/dev-ruby/actionmailbox/actionmailbox-7.1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/actionmailbox/actionmailbox-7.1.3.3.ebuild')
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-7.1.3.3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-ruby/actionmailbox/actionmailbox-7.1.3.3.ebuild b/dev-ruby/actionmailbox/actionmailbox-7.1.3.3.ebuild
index 04ce18c37c60..aaf83b522d6a 100644
--- a/dev-ruby/actionmailbox/actionmailbox-7.1.3.3.ebuild
+++ b/dev-ruby/actionmailbox/actionmailbox-7.1.3.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
@@ -21,7 +21,7 @@ SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz
LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE=""
+IUSE="test"
RUBY_S="rails-${PV}/${PN}"
@@ -39,7 +39,7 @@ ruby_add_rdepend "
ruby_add_bdepend "test? (
dev-ruby/bundler
- <dev-ruby/minitest-5.16
+ dev-ruby/minitest:5
dev-ruby/mocha
dev-ruby/propshaft
dev-ruby/rexml
@@ -53,7 +53,7 @@ all_ruby_prepare() {
# test run. This also requires handling some gemspecs.
sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|rack-test\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\|terser\|cookiejar\|cgi\|web-console\|trilogy\|error_highlight\|jbuilder\)/ s:^:#:" \
-e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
- -e '/group :\(cable\|doc\|job\|lint\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
+ -e '/group :\(cable\|doc\|job\|lint\|mdl\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
-e '/sqlite/ s/1.6.4/99/' \
-i ../Gemfile || die
rm ../Gemfile.lock || die