summaryrefslogtreecommitdiff
path: root/dev-ros/visp_tracker/visp_tracker-0.10.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/visp_tracker/visp_tracker-0.10.0-r2.ebuild')
-rw-r--r--dev-ros/visp_tracker/visp_tracker-0.10.0-r2.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ros/visp_tracker/visp_tracker-0.10.0-r2.ebuild b/dev-ros/visp_tracker/visp_tracker-0.10.0-r2.ebuild
deleted file mode 100644
index d4999b7b5199..000000000000
--- a/dev-ros/visp_tracker/visp_tracker-0.10.0-r2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/lagadic/vision_visp"
-KEYWORDS="~amd64 ~arm"
-VER_PREFIX="kinetic-"
-ROS_SUBDIR=${PN}
-CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
-
-inherit ros-catkin
-
-DESCRIPTION="Wraps the ViSP moving edge tracker provided by the ViSP visual servoing library into a ROS package"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=[threads]
- dev-ros/dynamic_reconfigure
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/image_proc
- dev-ros/image_transport
- dev-ros/nodelet
- dev-ros/resource_retriever
- dev-ros/roscpp
- dev-ros/sensor_msgs
- dev-ros/tf[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/ViSP:=[opencv,X]
- dev-libs/console_bridge:=
-"
-DEPEND="${RDEPEND}"
-if [ "${PV#9999}" = "${PV}" ] ; then
- S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
-fi
-PATCHES=( "${FILESDIR}/gcc6.patch" )