summaryrefslogtreecommitdiff
path: root/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.12.1.ebuild')
-rw-r--r--dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.12.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.12.1.ebuild b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.12.1.ebuild
new file mode 100644
index 000000000000..edbae8378ad0
--- /dev/null
+++ b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.12.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="noetic-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimates the camera position with respect to its effector using ViSP"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/image_proc
+ dev-ros/roscpp
+ dev-ros/sensor_msgs
+ dev-ros/visp_bridge
+ dev-ros/visp_tracker
+ sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-noetic-${PV}/${ROS_SUBDIR}"
+fi