summaryrefslogtreecommitdiff
path: root/dev-ros/urg_node/urg_node-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/urg_node/urg_node-9999.ebuild')
-rw-r--r--dev-ros/urg_node/urg_node-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-ros/urg_node/urg_node-9999.ebuild b/dev-ros/urg_node/urg_node-9999.ebuild
index c475a8ab1d44..b1e6973afc9f 100644
--- a/dev-ros/urg_node/urg_node-9999.ebuild
+++ b/dev-ros/urg_node/urg_node-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
CATKIN_HAS_MESSAGES=yes
inherit ros-catkin
@@ -23,8 +22,9 @@ RDEPEND="
dev-ros/roscpp
dev-ros/diagnostic_updater
dev-ros/laser_proc
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-libs/boost:=
"
-DEPEND="${RDEPEND}"