summaryrefslogtreecommitdiff
path: root/dev-ros/turtle_tf2/turtle_tf2-0.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/turtle_tf2/turtle_tf2-0.2.2-r1.ebuild')
-rw-r--r--dev-ros/turtle_tf2/turtle_tf2-0.2.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/turtle_tf2/turtle_tf2-0.2.2-r1.ebuild b/dev-ros/turtle_tf2/turtle_tf2-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..317903b4fac6
--- /dev/null
+++ b/dev-ros/turtle_tf2/turtle_tf2-0.2.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write a tf2 broadcaster and listener with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/turtlesim[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"