summaryrefslogtreecommitdiff
path: root/dev-ros/turtle_tf/turtle_tf-0.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/turtle_tf/turtle_tf-0.2.3.ebuild')
-rw-r--r--dev-ros/turtle_tf/turtle_tf-0.2.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/turtle_tf/turtle_tf-0.2.3.ebuild b/dev-ros/turtle_tf/turtle_tf-0.2.3.ebuild
new file mode 100644
index 000000000000..4e8d1ce0b0b2
--- /dev/null
+++ b/dev-ros/turtle_tf/turtle_tf-0.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write a tf broadcaster and listener with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/turtlesim[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"