summaryrefslogtreecommitdiff
path: root/dev-ros/tf/tf-1.13.2-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/tf/tf-1.13.2-r3.ebuild')
-rw-r--r--dev-ros/tf/tf-1.13.2-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ros/tf/tf-1.13.2-r3.ebuild b/dev-ros/tf/tf-1.13.2-r3.ebuild
new file mode 100644
index 000000000000..1bca719cd3f7
--- /dev/null
+++ b/dev-ros/tf/tf-1.13.2-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/geometry"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Maintains the relationship between frames in a tree structure over time"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads(+)]
+ dev-ros/angles
+ dev-ros/message_filters
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+PATCHES=( "${FILESDIR}/yaml.patch" )