summaryrefslogtreecommitdiff
path: root/dev-ros/test_rosservice/test_rosservice-1.15.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-1.15.11.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-1.15.11.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-1.15.11.ebuild b/dev-ros/test_rosservice/test_rosservice-1.15.11.ebuild
new file mode 100644
index 000000000000..b73420876103
--- /dev/null
+++ b/dev-ros/test_rosservice/test_rosservice-1.15.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosservice[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"