summaryrefslogtreecommitdiff
path: root/dev-ros/test_rosmaster/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_rosmaster/files')
-rw-r--r--dev-ros/test_rosmaster/files/empty.patch12
-rw-r--r--dev-ros/test_rosmaster/files/py3.patch54
-rw-r--r--dev-ros/test_rosmaster/files/yaml.patch53
3 files changed, 0 insertions, 119 deletions
diff --git a/dev-ros/test_rosmaster/files/empty.patch b/dev-ros/test_rosmaster/files/empty.patch
deleted file mode 100644
index 8ec371c917c0..000000000000
--- a/dev-ros/test_rosmaster/files/empty.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: test_rosmaster/CMakeLists.txt
-===================================================================
---- test_rosmaster.orig/CMakeLists.txt
-+++ test_rosmaster/CMakeLists.txt
-@@ -10,6 +10,7 @@ if(CATKIN_ENABLE_TESTING)
- String.msg
- Arrays.msg
- CompositeA.msg CompositeB.msg Composite.msg
-+ Empty.msg
- Embed.msg Floats.msg Simple.msg
- RosmsgA.msg
- RosmsgB.msg
diff --git a/dev-ros/test_rosmaster/files/py3.patch b/dev-ros/test_rosmaster/files/py3.patch
deleted file mode 100644
index 579d24f9f0b5..000000000000
--- a/dev-ros/test_rosmaster/files/py3.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 8f22c20e418abe4abe23e789eef517a16a50604d Mon Sep 17 00:00:00 2001
-From: Dirk Thomas <dirk-thomas@users.noreply.github.com>
-Date: Tue, 6 Aug 2019 12:50:24 -0700
-Subject: [PATCH] more Python 3 compatibility (#1782)
-
----
- test/test_rosmaster/test/nodes/testAllCommonFlows | 2 +-
- test/test_rosmaster/test/nodes/testMaster | 2 +-
- test/test_rosmaster/test/nodes/testSlave | 2 +-
- test/test_rospy/test/unit/test_genmsg_py.py | 8 +++++++-
- tools/rosgraph/test/test_roslogging.py | 5 ++++-
- tools/rosgraph/test/test_roslogging_user_logger.py | 5 ++++-
- tools/roslaunch/src/roslaunch/depends.py | 8 ++++----
- 7 files changed, 22 insertions(+), 10 deletions(-)
-
-diff --git a/test/test_rosmaster/test/nodes/testAllCommonFlows b/test/test_rosmaster/test/nodes/testAllCommonFlows
-index 4d3e053f8..a22ffb8d8 100755
---- a/test/test_rosmaster/test/nodes/testAllCommonFlows
-+++ b/test/test_rosmaster/test/nodes/testAllCommonFlows
-@@ -12,7 +12,7 @@ import sys, os
- BOOTSTRAP_VERSION = "0.1"
-
- # Read in ROS_ROOT
--if not os.environ.has_key('ROS_ROOT'):
-+if 'ROS_ROOT' not in os.environ:
- print """\nCannot run ROS: ROS_ROOT is not set.\nPlease set the ROS_ROOT environment variable to the
- location of your ROS install.\n"""
- sys.exit(-1)
-diff --git a/test/test_rosmaster/test/nodes/testMaster b/test/test_rosmaster/test/nodes/testMaster
-index f3ec36be4..4dca1cb4a 100755
---- a/test/test_rosmaster/test/nodes/testMaster
-+++ b/test/test_rosmaster/test/nodes/testMaster
-@@ -12,7 +12,7 @@ import sys, os
- BOOTSTRAP_VERSION = "0.1"
-
- # Read in ROS_ROOT
--if not os.environ.has_key('ROS_ROOT'):
-+if 'ROS_ROOT' not in os.environ:
- print """\nCannot run ROS: ROS_ROOT is not set.\nPlease set the ROS_ROOT environment variable to the
- location of your ROS install.\n"""
- sys.exit(-1)
-diff --git a/test/test_rosmaster/test/nodes/testSlave b/test/test_rosmaster/test/nodes/testSlave
-index cf70af08b..f8ea7cb47 100755
---- a/test/test_rosmaster/test/nodes/testSlave
-+++ b/test/test_rosmaster/test/nodes/testSlave
-@@ -12,7 +12,7 @@ import sys, os
- BOOTSTRAP_VERSION = "0.1"
-
- # Read in ROS_ROOT
--if not os.environ.has_key('ROS_ROOT'):
-+if 'ROS_ROOT' not in os.environ:
- print """\nCannot run ROS: ROS_ROOT is not set.\nPlease set the ROS_ROOT environment variable to the
- location of your ROS install.\n"""
- sys.exit(-1)
diff --git a/dev-ros/test_rosmaster/files/yaml.patch b/dev-ros/test_rosmaster/files/yaml.patch
deleted file mode 100644
index 2eb9c086b7e4..000000000000
--- a/dev-ros/test_rosmaster/files/yaml.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 29053c4832229efa7160fb944c05e3bc82e11540 Mon Sep 17 00:00:00 2001
-From: Martijn Buijs <Martijn.buijs@gmail.com>
-Date: Tue, 23 Apr 2019 18:20:12 +0200
-Subject: [PATCH] Switch to yaml.safe_load(_all) to prevent YAMLLoadWarning
- (#1688)
-
-* Switch to yaml.safe_load(_all) to prevent YAMLLoadWarning
-
-* Change all usages of yaml.load to yaml.safe_load
-
-* Extend PyYAML's SafeLoader and use it with `yaml.load`
-
-Also added convenience functions for using this loader for reuse in
-`roslaunch`
-
-* fix typo in rosparam.yaml_load_all
-
-* Modify Loader and SafeLoader in yaml module directly
-
-* Revert whitespace change
-
-* Revert unrelated change to import through global variable construction
----
- clients/rospy/src/rospy/client.py | 2 +-
- .../test/test_roslib_message.py | 2 +-
- .../client_verification/test_slave_api.py | 2 +-
- test/test_rosparam/test/check_rosparam.py | 8 ++---
- .../check_rosparam_command_line_online.py | 2 +-
- .../check_rosservice_command_line_online.py | 4 +--
- test/test_rostopic/test/test_rostopic_unit.py | 30 +++++++++----------
- tools/rosbag/src/rosbag/bag.py | 2 +-
- tools/rosgraph/src/rosgraph/roslogging.py | 2 +-
- tools/roslaunch/src/roslaunch/loader.py | 4 +--
- .../test/unit/test_roslaunch_dump_params.py | 4 +--
- tools/rosparam/src/rosparam/__init__.py | 7 ++++-
- tools/rosservice/src/rosservice/__init__.py | 4 +--
- tools/rostopic/src/rostopic/__init__.py | 6 ++--
- tools/topic_tools/scripts/relay_field | 2 +-
- 15 files changed, 43 insertions(+), 38 deletions(-)
-
-diff --git a/test/test_rosmaster/test/client_verification/test_slave_api.py b/test/test_rosmaster/test/client_verification/test_slave_api.py
-index 63d919c72..8614c045d 100755
---- a/test/test_rosmaster/test/client_verification/test_slave_api.py
-+++ b/test/test_rosmaster/test/client_verification/test_slave_api.py
-@@ -106,7 +106,7 @@ def __init__(self, *args, **kwds):
- def load_profile(self, filename):
- import yaml
- with open(filename) as f:
-- d = yaml.load(f)
-+ d = yaml.safe_load(f)
- self.required_pubs = d.get('pubs', {})
- self.required_subs = d.get('subs', {})
-