summaryrefslogtreecommitdiff
path: root/dev-ros/smclib/smclib-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/smclib/smclib-9999.ebuild')
-rw-r--r--dev-ros/smclib/smclib-9999.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ros/smclib/smclib-9999.ebuild b/dev-ros/smclib/smclib-9999.ebuild
new file mode 100644
index 000000000000..bb3fba1fe9c0
--- /dev/null
+++ b/dev-ros/smclib/smclib-9999.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="The State Machine Compiler (SMC) converts the description of a state machine into source code"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"