summaryrefslogtreecommitdiff
path: root/dev-ros/smach/smach-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/smach/smach-2.0.1.ebuild')
-rw-r--r--dev-ros/smach/smach-2.0.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/smach/smach-2.0.1.ebuild b/dev-ros/smach/smach-2.0.1.ebuild
new file mode 100644
index 000000000000..8e7347a0da5d
--- /dev/null
+++ b/dev-ros/smach/smach-2.0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Task-level architecture for rapidly creating complex robot behavior"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"