summaryrefslogtreecommitdiff
path: root/dev-ros/settlerlib/settlerlib-0.10.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/settlerlib/settlerlib-0.10.15.ebuild')
-rw-r--r--dev-ros/settlerlib/settlerlib-0.10.15.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/settlerlib/settlerlib-0.10.15.ebuild b/dev-ros/settlerlib/settlerlib-0.10.15.ebuild
new file mode 100644
index 000000000000..f002fa2984e2
--- /dev/null
+++ b/dev-ros/settlerlib/settlerlib-0.10.15.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helper functions for creating a settler for a specific sensor channel"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/rosconsole
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-cpp/gtest )"