summaryrefslogtreecommitdiff
path: root/dev-ros/self_test/self_test-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/self_test/self_test-9999.ebuild')
-rw-r--r--dev-ros/self_test/self_test-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-ros/self_test/self_test-9999.ebuild b/dev-ros/self_test/self_test-9999.ebuild
index 9d24c5969971..508f8474c698 100644
--- a/dev-ros/self_test/self_test-9999.ebuild
+++ b/dev-ros/self_test/self_test-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/diagnostics"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
@@ -14,11 +14,16 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/diagnostic_msgs
dev-ros/diagnostic_updater
dev-ros/roscpp
dev-ros/rostest
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-ros/rostest )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}