summaryrefslogtreecommitdiff
path: root/dev-ros/self_test/self_test-1.9.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/self_test/self_test-1.9.6.ebuild')
-rw-r--r--dev-ros/self_test/self_test-1.9.6.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-ros/self_test/self_test-1.9.6.ebuild b/dev-ros/self_test/self_test-1.9.6.ebuild
deleted file mode 100644
index 508f8474c698..000000000000
--- a/dev-ros/self_test/self_test-1.9.6.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros/diagnostics"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Robot self-test node"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/diagnostic_updater
- dev-ros/roscpp
- dev-ros/rostest
- dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}
- dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? ( dev-ros/rostest )"
-
-src_test() {
- export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
- ros-catkin_src_test
-}