summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_top/rqt_top-0.4.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rqt_top/rqt_top-0.4.10.ebuild')
-rw-r--r--dev-ros/rqt_top/rqt_top-0.4.10.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rqt_top/rqt_top-0.4.10.ebuild b/dev-ros/rqt_top/rqt_top-0.4.10.ebuild
new file mode 100644
index 000000000000..b312ed9dd5a4
--- /dev/null
+++ b/dev-ros/rqt_top/rqt_top-0.4.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_top"
+
+inherit ros-catkin
+
+DESCRIPTION="RQT plugin for monitoring ROS processes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/psutil[\${PYTHON_USEDEP}]")
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"