summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_service_caller/rqt_service_caller-0.4.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rqt_service_caller/rqt_service_caller-0.4.10.ebuild')
-rw-r--r--dev-ros/rqt_service_caller/rqt_service_caller-0.4.10.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rqt_service_caller/rqt_service_caller-0.4.10.ebuild b/dev-ros/rqt_service_caller/rqt_service_caller-0.4.10.ebuild
new file mode 100644
index 000000000000..256f3a0fafa8
--- /dev/null
+++ b/dev-ros/rqt_service_caller/rqt_service_caller-0.4.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_service_caller"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for calling arbitrary services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rosservice[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"