summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.9.ebuild')
-rw-r--r--dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.9.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.9.ebuild b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.9.ebuild
new file mode 100644
index 000000000000..5e331b7e803c
--- /dev/null
+++ b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_runtime_monitor"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin viewing DiagnosticsArray messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/qt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}"