summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild')
-rw-r--r--dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild b/dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild
new file mode 100644
index 000000000000..9e3b5a9ca419
--- /dev/null
+++ b/dev-ros/rqt_bag/rqt_bag-0.5.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_bag"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and replaying ROS bag files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_SINGLE_USEDEP}]
+"