summaryrefslogtreecommitdiff
path: root/dev-ros/rotate_recovery/rotate_recovery-1.17.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rotate_recovery/rotate_recovery-1.17.1-r1.ebuild')
-rw-r--r--dev-ros/rotate_recovery/rotate_recovery-1.17.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rotate_recovery/rotate_recovery-1.17.1-r1.ebuild b/dev-ros/rotate_recovery/rotate_recovery-1.17.1-r1.ebuild
new file mode 100644
index 000000000000..df5c9a55570a
--- /dev/null
+++ b/dev-ros/rotate_recovery/rotate_recovery-1.17.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts performing a 360 degree rotation of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles:0
+ dev-ros/base_local_planner
+ dev-ros/costmap_2d
+ dev-cpp/eigen:3
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/nav_core-1.16
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules"